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Catcher_v3.1228.00 (1/6)Catcher_v3.1228.00 (1/6)

▪ Update default filter
– (MMI)Video Stream
– (MMI)Java UI

▪ Update config.ini to support new PID of USB driver



Catcher_v3.1228.00 Catcher_v3.1228.00 (2/6(2/6))

▪ Enhance SWLA filter
– Support to choose “All On/All Off” in Functions, Extra/Monitor 

info and Labels
– Export/Import filter setting of SWLA



Catcher_v3.1228.00 Catcher_v3.1228.00 (3/6(3/6))

▪ Support to config smart phone logging threshold
– User can set the buffer threshold and period for smart phone in 

[Advanced] -> [Config Smart Phone Logging]



Catcher_v3.1228.00 Catcher_v3.1228.00 (4/6(4/6))

▪ Support smart phone USB logging on dual talk project 
– If you want to log MT6252D modem log in MT6573+MT6252D 

project, please choose “Smart Phone USB Logging (MD 2)” in 
configure port dialog. Otherwise, please choose “Smart Phone 
USB Logging (MD 1)”.



Catcher_v3.1228.00 Catcher_v3.1228.00 (5/6(5/6))

▪ Enhance Catcher’s decode speed 
– If you have encountered many “Catcher processing buffer full” 

error messages in Catcher information view, please upgrade to 
this version of Catcher to improve Catcher’s decode speed.

▪ Convert dmp file in folder and subfolder ▪ Convert dmp file in folder and subfolder 
– Usage: Catcher.exe *.ini file
– Ini file example: 

[Catcher]
Dump File = {D:\test\dmp} 
Catcher will convert all *.dmp in the folder and subfolder 
in “D:\test\dmp” to *.clg.



Catcher_v3.1228.00 Catcher_v3.1228.00 (6/6(6/6))

▪ Support to save to txt in SWTR pie chart 
– Please use it by right click -> [Save to Text] in “Software Tracer 

Pie Char” view.

▪ Support to copy message raw data for kal_buffer_trace
– Please use it by right click -> [Only Copy Message Raw Data] – Please use it by right click -> [Only Copy Message Raw Data] 

in PS integrated view.
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Catcher_v3.1220.00 (1/3)Catcher_v3.1220.00 (1/3)

▪ Update default filter
– (PS)SIM/STK
– (MMI)Phonebook/CallLog
– (MMI)Media Player app
– (MMI)PHOTO EDITOR
– (MMI)GPS
– VoWLAN-Network
– (MMI)Video Stream
– (PS)WAP over WIFI– (PS)WAP over WIFI
– (PS)WAP MMS
– (PS)GSM Network Search
– (MMI)Java Network
– (MMI)MBBMS
– AGPS
– Certman TLS Security
– Modem AT command
– (3G_FDD)All
– (PS)HSPA High Speed Transmission
– DAK
– (MMI)Opera Browser
– Add (MMI)Cloud service



Catcher_v3.1220.00 (2/3)Catcher_v3.1220.00 (2/3)

▪ Merge multiple dmp files 
– In [Controls] -> [Open Dump Files (Batch)], you can merge 

several dmp files by selecting “Merge these dmp files into a 
clg”.

– Catcher will use the DB of the first dmp file and save clg as 
<FirstDmpName>_merge.clg.<FirstDmpName>_merge.clg.



Catcher_v3.1220.00 (3/3)Catcher_v3.1220.00 (3/3)

▪ Support to start SWLA when target is powered on 
– For load in W1216 and later in MAUI and 11B, you can use 

Catcher to start SWLA by fefault when target is powered on. 
Please choose to enable or disable this feature by [Advanced]-
>[Software LA] ->[Config Software LA].

▪ Support to delete virtual channel files, AST logs logs 
when clear



Catcher_v3.1212.00 (1/3) Catcher_v3.1212.00 (1/3) 

▪ Auto find lost message in Find by filter 
– If you check “Include lost messages” , the packet drop 

message will be included in the find result



Catcher_v3.1212.00 (2/3) Catcher_v3.1212.00 (2/3) 

▪ Support to calculate time difference of messages in 
Comment View 
– In Comment view, right click -> Calculate Time Difference, 

Catcher would update the “Time Difference” field.
– Time difference = |(Time of msg1 – Time of msg 2)| * 0.004615



Catcher_v3.1212.00 (3/3) Catcher_v3.1212.00 (3/3) 

▪ USB auto connect enhancement 
– Catcher will reconnect to different port number of USB by 

default. 
– If you want to Catcher to always reconnect to the same port, 

please check menu: [Config] -> [Options] -> [Options] USB 
Auto Re-connect to The Same COM Port Number.Auto Re-connect to The Same COM Port Number.

▪ Bug fix: Failed to GDI snapshot when TST buffer is too 
small



Catcher_v3.1208.00 (1/4) Catcher_v3.1208.00 (1/4) 

▪ Update default filter
– (2G)Field Trial
– (MMI)SIM/Security Setup/SAT
– (MMI)Call Management
– (MMI)Phonebook/CallLog
– (MMI)SMS
– (MMI)Camera/Video/TV OUT/Webcam/Photo editor/QR code
– (MMI)Cosmos Gallery
– (MMI)IMPS– (MMI)IMPS
– (MMI)Ebook Reader
– (MMI)PHOTO EDITOR
– (MMI)WAP MMS
– (MMI)Video Stream
– (PS)WAP MMS
– (MMI)Java JavaAgency
– (MMI)Java MMAPI
– (MMI)Mobile TV
– VT – ALL
– (3G_FDD)All
– (3G_TDD)All
– (PS)HSPA High Speed Transmission



Catcher_v3.1208.00 (2/4)Catcher_v3.1208.00 (2/4)

▪ Default filter UI enhancement
– Change and group default filter list to tree view

– Provide selected default filters info
– Imported filters will be group in ‘Import’ and add file name as 

prefix



Catcher_v3.1208.00 (3/4)Catcher_v3.1208.00 (3/4)

▪ Add log lost message to Catcher information view 
– You can see log lost message in [View] -> Catcher information 

view if the file is logged by this version of Catcher



Catcher_v3.1208.00 (4/4)Catcher_v3.1208.00 (4/4)

▪ Speed up find by filter
– A test case shows that the speed of searchClg and find by filter 

was improved from 8 minutes to 50 seconds

▪ Add catcher information about start SWLA. Show 
message box when start SWLA succeededmessage box when start SWLA succeeded

▪ Clg2txt: add -nobuf to skip local parameter and peer 
buffer of message 



Catcher_v3.1204.00 (1/3)Catcher_v3.1204.00 (1/3)

▪ Update default filter
– Modify Modem_Sleep_Mode
– Modify (MMI)Phonebook
– Modify (MMI)Camera/Video/TV OUT/Webcam/Photo editor/QR code]
– Modify (MMI)ImageViewer
– Modify (MMI)Email
– Modify (MMI)Bluetooth(MTKBT)-CM/HFP/HSP
– Modify (MMI)Bluetooth(MTKBT)-FTP/OPP/BPP/SPP
– Modify (MMI)Unified Message
– Modify (MMI)USB
– Modify (MMI)WAP MMS
– Modify (MMI)Video Stream
– Modify (MMI)Java Network– Modify (MMI)Java Network
– Modify (MMI)Java MMAPI
– Modify Certman TLS Security
– Modify (PS)HSPA High Speed Transmission
– Rename (MMI)Audio apps/CTM/A2DP/AVRCP/VR to (MMI)General audio Playback/Record Related (including User Profiles, 

FM Radio, Sound Recorder)
– Rename (MMI)GPIO(Charger/LED/Backlight) to (MMI)GPIO(Charger/Backlight/Vibrate/Earphone)
– Add (MMI)Notification
– Add (MMI)BT Audio (A2DP/AVRCP/SCO)
– Add (MMI)Music Player app
– Add (MMI)Cosmos Gallery 
– Add (MMI)Java JavaAgency
– Add (MMI)Java NFC
– Add (MMI)Opera Browser
– Add (MMI)Provisioning Message
– Add (MMI)Launcher, Screen Lock, Widget, and Wallpaper
– Delete (MMI)User Profile 
– Merge (MMI)Java PIM  and (MMI)Java Message to (MMI) Java Message & PIM 



Catcher_v3.1204.00 (2/3)Catcher_v3.1204.00 (2/3)

▪ Workspace enhancement 
– Catcher will maintain UI setting (e.g., window placement, 

column width…) when users switch different DB / log file and 
reopen Catcher.

– Please select the checkbox: “Save all setting including non-UI 
part” when saving a workspace if you want to save all setting part” when saving a workspace if you want to save all setting 
including DB path, COM port, filter and mode



Catcher_v3.1204.00 (3/3)Catcher_v3.1204.00 (3/3)

▪ Update clgcap
– Speed up conversion
– [R8Generic] Convert 2G packets correctly



Catcher_v3.1152 Catcher_v3.1152 (1/5)(1/5)

▪ Update default filter
– Update (MMI)Mobile TV
– (3G_TDD)All, (3G_TDD)All@TDD_11A

▪ ExtractDBGInfo: compare version of elf and bin



Catcher_v3.1152 (2/5)Catcher_v3.1152 (2/5)

▪ Set find range by timestamp in Find/Find by filter 



Catcher_v3.1152 (3/5)Catcher_v3.1152 (3/5)

▪ Support Goto a timestamp



Catcher_v3.1152 (4/5)Catcher_v3.1152 (4/5)

▪ Detect received bytes in status bar and Catcher 
information

▪ Add function and labels in SWLA filter

▪ Update clgcap



Catcher_v3.1152 (5/5)Catcher_v3.1152 (5/5)

▪ Support to show EM data in graph
– Select Advanced -> Engineering Mode -> Engineering Mode 

Views -> Graph



Catcher_v3.1144Catcher_v3.1144

▪ Find by filter related enhancement
– Support to add a filter condition by checking “Search by filter 

setting”
– Support to export groups to ini file and load groups when the 

dialog is opened

▪ Check MCDDLL version information

▪ Command line ini file enhancement
– Support to enter L1 validation mode or unit test on target mode: 

“Mode = L1Validation / UnitTestonTarget”
– Support to connect or not connect when Catcher is launched: 

“Connect = true/false



Catcher_v3.1140 (1/2)Catcher_v3.1140 (1/2)

▪ Update default filter
– Rename “(!)Field Trial” to “(2G)Field Trial”
– Rename “(3G)All” to “(3G_FDD)All”
– Rename “(HSPA)” to “(PS)HSPA High Speed Transmission”
– Rename “(!)Field Trial_sleepMode” to “Modem_Sleep_Mode”
– Rename “(!)Field Trial_DAK” to “DAK”

• “DAK” only contains DAK related filters. • “DAK” only contains DAK related filters. 
• Use “DAK” + “(2G)Field Trial” or “(3G_FDD)All” if you also want to log 

general modem information.
– Remove “(!)Field Trial + AGPS”. 

• Use “(2G)Field Trial” or “(3G_FDD)All” for general AGPS test.
• Use “AGPS” + “(2G)Field Trial” or “(3G_FDD)All” if you also want log 

time sync information.
– Update “(MMI)Camera/Video/TV OUT/Webcam/Photo editor/QR 

code”
– Update “(3G_TDD)All”



Catcher_v3.1140 (2/2)Catcher_v3.1140 (2/2)

▪ Remove 2G file size constraint of clg file 
– Please upgrade to this version to read the new format of clg file.
– For the feature of auto save large files, Catcher now saves file 

when its size is larger than 3.5 G (rather than 1.2 G) due to 
memory usage concern.

▪ SWLA related enhancement
– Support to deduct overhead of SWLA in Statistics view
– Support to calculate function execution ratio = function time / 

start time ~ end time



Catcher_v3.1136.00 (1/4)Catcher_v3.1136.00 (1/4)

▪ Update default filter
– (!)Field Trial
– (MMI)Video Stream
– (!)Field Trial + AGPS
– (3G)All
– (3G_TDD)All– (3G_TDD)All
– (HSPA)
– Remove default filter:

(!)Field Trial with UL_data
(!)Field Trial_GSM Call Test
(!)FTA
(!)FTA@PS_11A
(!)SIM2_Only
WISDOM - ALL



Catcher_v3.1136.00 (2/4)Catcher_v3.1136.00 (2/4)

▪ Calculate local time for SD card logging 
– For SD card logging, Catcher would calculate local time as the 

time of logging. 
– Note that Catcher uses the file name of *.dmp as the local time 

of the first message. 
– If the calculation result is incorrect, you can right click on any – If the calculation result is incorrect, you can right click on any 

message and then choose “Adjust local time” to modify the 
local time of all messages



Catcher_v3.1136.00 (3/4)Catcher_v3.1136.00 (3/4)

▪ Enhance converting caller address function 
– Support to disable auto convert when logging
– Support to convert all PS/SYS traces in offline mode



Catcher_v3.1136.00 (4/4)Catcher_v3.1136.00 (4/4)

▪ Support to read/write register via script
– Press Load button in Register R/W dialog to load script
– The script format:  

//Address R/W Value
0x810D_0300 W 0x0000FCFE

▪ Add and extract mmv2 in memory dump

0x810D_0300 W 0x0000FCFE
0x810D_030C W 0000_0000_0000_0000_1111_0110_1111_0011
0x810D_0308 R
0x810D_033C R



Catcher_v3.1132.00 (1/3)Catcher_v3.1132.00 (1/3)

▪ Update default filter
– Modified (3G)All@PS_11A
– Modified (HSPA)@PS_11A



Catcher_v3.1132.00 (2/3)Catcher_v3.1132.00 (2/3)

▪ Export filter setting to catcher_filter.bin



Catcher_v3.1132.00 (3/3)Catcher_v3.1132.00 (3/3)

▪ Save SWLA statistics to txt file
– Please right click in Software LA Statistics view and choose 

“Save to Test” to enable this feature.

▪ Support Software Tracer
– Please use this feature in [Advanced] -> [Software Tracer]– Please use this feature in [Advanced] -> [Software Tracer]



Catcher_v3.1128.00 (1/4)Catcher_v3.1128.00 (1/4)

▪ Default filter refinement 
– We have merged some similar and removed unnecessary 

filters in this version
• Before : 115
• Now : 85

– Merge “(MMI)Download Agent” to “(PS)WAP over WIFI”
– Merge “(MMI)SS/Call Setup” to “(MMI)Call Management”
– Merge “(PS)GPRS” to “(!)Field Trial”
– Merge “(PS)WAP over GPRS” to “(PS)WAP over WIFI”
– Merge “(PS)WAP Push” to “(PS)WAP over WIFI”
– Rename “(MMI)Flash SW” as “(MMI)PHOTO EDITOR”
– Rename “(MMI)Image(JPEG)” as “(MMI)ImageViewer”
– Rename “(MMI)GPS/GIS” as “(MMI)GPS”



Catcher_v3.1128.00 (2/4)Catcher_v3.1128.00 (2/4)

▪ Static Register R/W tool 
– Support to read/write register from menu [Advanced] -> [Static 

Register R/W], and compare the result with golden value
– Golden value is retrieved from configuration files in 

RegisterRW folder
– The result can be saved into temp files– The result can be saved into temp files



Catcher_v3.1128.00 (3/4)Catcher_v3.1128.00 (3/4)

▪ Enhance Comment functionality 
– Support to add comment to multiple messages by multiple 

selections. 
– Support to add group of comment. When adding a comment, 

you could assign a group to this comment and only see a group 
of comments in the comment view by right clicking and select of comments in the comment view by right clicking and select 
“only show group…”. 

– Add “Comment”, “Time” and “Group” in the comment view.



Catcher_v3.1128.00 (4/4)Catcher_v3.1128.00 (4/4)

▪ Embed database and MCDDLL to dmp file
– In offline logging, Catcher would save the database and 

MCDDLL to the *.dmp file. Users don’t have to select the 
database when opening the dump file in the new format.

▪ Rearrange menu items▪ Rearrange menu items
– Group some menu items in [Advanced]
– Move [View] -> [Options] to [Config] -> [Options]



Catcher_v3.1120.00 (1/4)Catcher_v3.1120.00 (1/4)

▪ Support Smart Phone Modem Logging via SD card and USB
– For SD Logging

• Please select SD Logging Mode in target Engineering Mode -> 
SystemLog. Modem logs will be saved under sdcard/mtklog/mdlog, 
users can open logs by Catcher

– For USB Logging– For USB Logging
• Please select USB Logging Mode in target Engineering Mode -> 

SystemLog. Set “Smart Phone Logging” in Catcher configuration 
dialog

– Please Document\CatcherLogging.pdf for more details



Catcher_v3.1120.00 (2/4)Catcher_v3.1120.00 (2/4)

▪ Support to add checksum and compress the 
MemoryDump.bin
– The new version of MemoryDump.bin will be compressed and 

have checksum. Please use the latest ExtractDBGInfo.exe to 
extract it.

– Please upgrade your Catcher / ExtractDBGInfo immediately to – Please upgrade your Catcher / ExtractDBGInfo immediately to 
support new version of MemoryDump.bin.



Catcher_v3.1120.00 (3/4)Catcher_v3.1120.00 (3/4)

▪ Update default filter
– Modified (PS)SIM/STK
– Modified (MMI)Video Stream
– AGPS
– (!)Field Trial + AGPS



Catcher_v3.1120.00 (4/4)Catcher_v3.1120.00 (4/4)

▪ Support to load TST inject template file
– Catcher would load tst_inject_string_template.txt in the Catcher 

folder. For some common used commands, you could add 
them in the template file so that you could see the shortcut 
name in the toolbar.

▪ Remove the constraint that only 26 conditions are ▪ Remove the constraint that only 26 conditions are 
supported in “Find by Filter”



Catcher_v3.1116.00 (1/2)Catcher_v3.1116.00 (1/2)

▪ Update default filter
– Modified (!)Field Trial, (!)Field Trial@PS_11A
– Modified (!)Field Trial_GSM Call Test
– Modified (!)Field Trial_sleepMode
– Modified (!)FTA, (!)FTA@PS_11A
– Modified (!)Field Trial with UL_data
– Modified (!)SIM2_Only
– Modified Charging
– Modified (3G)All, (3G)All@PS_11A
– Modified (3G_TDD)All, (3G_TDD)All@TDD_11A
– Modified (HSPA), (HSPA)@PS_11A



Catcher_v3.1116.00 (2/2)Catcher_v3.1116.00 (2/2)

▪ Support multiple NetSim and MoDIS
– In [Tools]->[Register]->[Multiple MoDIS and NetSim], you could 

choose which MoDIS to connect and which NetSim to register.



Catcher_v3.1112.00 (1/7)Catcher_v3.1112.00 (1/7)

▪ Update default filter
– Add (3G_TDD)All & (3G_TDD)All@TDD_11A
– Add (MMI)MBBMS
– Modified VT - ALL
– Modified Field Trial + AGPS
– Modified (3GVT)All
– Modified (MMI)Camera/Video/TV OUT/Webcam/Photo 

editor/QR code



Catcher_v3.1112.00 (2/7)Catcher_v3.1112.00 (2/7)

▪ Support R5R6 Engineer mode
– Add R5R6 related information in “CC/MM/RR information”,  

“3G/IRAT Status”,  and “GPRS NAS Layer” pages.



Catcher_v3.1112.00 (3/7)Catcher_v3.1112.00 (3/7)

▪ Embed MCDDLL into clg file
– Catcher will embed MCDDLL into clg file, so you no longer 

have to copy MCDDLL into the clg folder. 
– In [View]->[Option]->[Option]MCDDLL Options, you could 

disable this feature and choose the source of MCDDLL.



Catcher_v3.1112.00 (4/7)Catcher_v3.1112.00 (4/7)

▪ Support offline logging on VITI DB
– Steps to log VITI messages:

• Select DB in mcu\tst\database_classb_umts\viti_db\ folder 
• Select port and baud rate
• Use offline logging (choose [Controls]->[Connect (Off-line Parse)])
• Click “Disconnect” button, and then save a *.dmp file• Click “Disconnect” button, and then save a *.dmp file

– Note that you will not see messages in PS view when you use 
offline logging.



Catcher_v3.1112.00 (5/7)Catcher_v3.1112.00 (5/7)

▪ Support multiple filter
– Enable [Advanced]->[Multi Filter Mode].
– Choose “Filter”, you could add multiple filters. Choose detail 

filter’s setting by double clicking on a filter.
– In [View]->[PS Integrated], you could see different messages 

for different filters.for different filters.



Catcher_v3.1112.00 (6/7)Catcher_v3.1112.00 (6/7)

▪ Include Clg2Txt.exe
– You could use Clg2Txt.exe to translate a clg file to a txt file.
– Usage: Clg2Txt InputFile(*.clg) [-std] [-mcd

MCDDLL_FilePath(*.dll) / -mcd] [-p PS_OutputFile(*.txt)] [-s 
SYS_OutputFile(*.txt)] [-b Basic_OutputFile(*.txt)]”
InputFile Specified input clg fileInputFile Specified input clg file

-std Print result in stdout
-mcd Specified MCDDLL path or use embedded 

MCDDLL
-p Save PS message to the text file
-s Save Sys trace to the text file
-b Save basic information to the text file



Catcher_v3.1112.00 (7/7)Catcher_v3.1112.00 (7/7)

▪ Support additional command in External menu


